$re = '~^[wW][a-zA-Z0-9]*(\/[a-zA-Z0-9]+)*?\/\d+$~m';
$str = 'w1/2a/11
w1//01
w1/2a/2
wa/sdf/21
w23a/we2/123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);