using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<date>[^\s]+) (?<time>[^\s]+) - (?<message>.*)$";
string input = @"2016-08-17 20:07:22 - Hello there";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}