const regex = /^(?<date>[^\s]+) (?<time>[^\s]+) - (?<message>.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<date>[^\\s]+) (?<time>[^\\s]+) - (?<message>.*)$', '')
const str = `2016-08-17 20:07:22 - Hello there`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}