package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<date>[^\s]+) (?<time>[^\s]+) - (?<message>.*)$`)
var str = `2016-08-17 20:07:22 - Hello there`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}