re = /^(?<date>[^\s]+) (?<time>[^\s]+) - (?<message>.*)$/
str = '2016-08-17 20:07:22 - Hello there'
# Print the match result
str.match(re) do |match|
puts match.to_s
end