#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\S)\1{3,}|(\S)\2{2}"
Local $sString = "aaaa**!!!cccc333**" & @CRLF & _
"aaabbbbaaa" & @CRLF & _
"aaabbbbbbaaa****ccc" & @CRLF & _
"!!! aaaabbbaaa ccc!!!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")