re = /(\S)\1{3,}|(\S)\2{2}/m
str = 'aaaa**!!!cccc333**
aaabbbbaaa
aaabbbbbbaaa****ccc
!!! aaaabbbaaa ccc!!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end