$re = '/(\S)\1{3,}|(\S)\2{2}/m';
$str = 'aaaa**!!!cccc333**
aaabbbbaaa
aaabbbbbbaaa****ccc
!!! aaaabbbaaa ccc!!!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);