import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ?(\\d+.\\d+|\\d+)(-)(\\d+.\\d+|\\d+)";
final String string = "FAST.65\n"
+ "FAST.65-160\n"
+ "<114\n"
+ ">289\n"
+ "<=152\n"
+ ">=107\n"
+ "10.9\n"
+ "111.11\n"
+ "12.20\n\n\n"
+ "LESS THAN 0.1\n"
+ "LESS THAN 5\n"
+ "LESS THAN 9999\n\n"
+ "< 0.1\n"
+ "< 999\n"
+ " < 99999.99\n"
+ " \n"
+ "<5\n"
+ "< 5\n"
+ "<5.55\n\n"
+ "<= 6\n"
+ "LE 6\n"
+ "<=666.666\n\n"
+ "LT 6\n"
+ "LT 6.666\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}