import Foundation
let pattern = #" ?(\d+.\d+|\d+)(-)(\d+.\d+|\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
FAST.65
FAST.65-160
<114
>289
<=152
>=107
10.9
111.11
12.20
LESS THAN 0.1
LESS THAN 5
LESS THAN 9999
< 0.1
< 999
< 99999.99
<5
< 5
<5.55
<= 6
LE 6
<=666.666
LT 6
LT 6.666
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}