using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)\s?=\s?(['\""]?)(\S*)\2$";
string input = @"param1=abc
param2 = abc
param3 = ""ab'c""
param4='a""b""c'
param5=""abc=def""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}