$re = '/^(\w+)\s?=\s?([\'\"]?)(\S*)\2$/m';
$str = 'param1=abc
param2 = abc
param3 = "ab\'c"
param4=\'a"b"c\'
param5="abc=def"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);