#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)[^\w\s]+"
Local $sString = "Как выбрать все спецсимволы регулярным выражением?" & @CRLF & _
"Всем привет! Подскажите, как выбрать все спциальные символы?" & @CRLF & _
"Всякие доллары, + ~ стрелки и прочую дичь"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")