re = /[^\w\s]+/
str = 'Как выбрать все спецсимволы регулярным выражением?
Всем привет! Подскажите, как выбрать все спциальные символы?
Всякие доллары, + ~ стрелки и прочую дичь'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end