// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[^\w\s]+").unwrap();
let string = "Как выбрать все спецсимволы регулярным выражением?
Всем привет! Подскажите, как выбрать все спциальные символы?
Всякие доллары, + ~ стрелки и прочую дичь";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}