$re = '/[^\w\s]+/u';
$str = 'Как выбрать все спецсимволы регулярным выражением?
Всем привет! Подскажите, как выбрать все спциальные символы?
Всякие доллары, + ~ стрелки и прочую дичь';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);