package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`[^\w\s]+`)
    var str = `Как выбрать все спецсимволы регулярным выражением?
Всем привет! Подскажите, как выбрать все спциальные символы?
Всякие доллары, + ~ стрелки и прочую дичь`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}