# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+?\/p\/[^\/]+\///;t' <<< "https://www.reading.am/p/4Nix/http://www.nejm.org/doi/full/10.1056/NEJMsa1202099#t=article"