#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^.+?/p/[^/]+/"
Local $sString = "https://www.reading.am/p/4Nix/http://www.nejm.org/doi/full/10.1056/NEJMsa1202099#t=article"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)