$re = '@^.+?/p/[^/]+/@';
$str = 'https://www.reading.am/p/4Nix/http://www.nejm.org/doi/full/10.1056/NEJMsa1202099#t=article';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;