// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^.+?/p/[^/]+/").unwrap();
let string = "https://www.reading.am/p/4Nix/http://www.nejm.org/doi/full/10.1056/NEJMsa1202099#t=article";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}