# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.+?/p/[^/]+/"
test_str = "https://www.reading.am/p/4Nix/http://www.nejm.org/doi/full/10.1056/NEJMsa1202099#t=article"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.