#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\+[\d]{11,14}"
Local $sString = "Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/" & @CRLF & _
"IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:"{};'[]|\<>?,./" & @CRLF & _
"IVANOV Ivan !@#$$^&*(_+1234567890-=~`:"{};'[]|\<>?,./" & @CRLF & _
"+9991234567" & @CRLF & _
"+19991234567" & @CRLF & _
"+129991234567" & @CRLF & _
"+1239991234567" & @CRLF & _
"+12349991234567" & @CRLF & _
"+1 999 1234567" & @CRLF & _
"+1234 (999) 123-45-67" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)