using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+[\d]{11,14}";
string substitution = @"";
string input = @"Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:""{};'[]|\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~`:""{};'[]|\<>?,./
+9991234567
+19991234567
+129991234567
+1239991234567
+12349991234567
+1 999 1234567
+1234 (999) 123-45-67
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}