const regex = /\+[\d]{11,14}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+[\\d]{11,14}', 'gi')
const str = `Иванов Иван иванович !@#\$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#\$\$^&*(_+1234567890-=~\`:"{};'[]|\\<>?,./
IVANOV Ivan !@#\$\$^&*(_+1234567890-=~\`:"{};'[]|\\<>?,./
+9991234567
+19991234567
+129991234567
+1239991234567
+12349991234567
+1 999 1234567
+1234 (999) 123-45-67
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);