import Foundation
let pattern = #"\+[\d]{11,14}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:"{};'[]|\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~`:"{};'[]|\<>?,./
+9991234567
+19991234567
+129991234567
+1239991234567
+12349991234567
+1 999 1234567
+1234 (999) 123-45-67
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)