#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:"[^"]+"|'[^']+')|(?<G><\s?(\w+).*\/>)"
Local $sString = " <div>" & @CRLF & _
" TESAT ${this.TT1}" & @CRLF & _
" ${am.map( (item, i) => `<li>${item}</li>${i}`).join('')}" & @CRLF & _
" <Label width="100px" behaviour="fixed" />" & @CRLF & _
"< Label123 width="100px" behaviour="fixed" />" & @CRLF & _
""<Label123 width="100px" behaviour="fixed"/>"" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")