import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"[^\"]+\"|'[^']+')|(?<G><\\s?(\\w+).*\\/>)";
final String string = " <div>\n"
+ " TESAT ${this.TT1}\n"
+ " ${am.map( (item, i) => `<li>${item}</li>${i}`).join('')}\n"
+ " <Label width=\"100px\" behaviour=\"fixed\" />\n"
+ "< Label123 width=\"100px\" behaviour=\"fixed\" />\n"
+ "\"<Label123 width=\"100px\" behaviour=\"fixed\"/>\"\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}