import Foundation
let pattern = #"(?:"[^"]+"|'[^']+')|(?<G><\s?(\w+).*\/>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<div>
TESAT ${this.TT1}
${am.map( (item, i) => `<li>${item}</li>${i}`).join('')}
<Label width="100px" behaviour="fixed" />
< Label123 width="100px" behaviour="fixed" />
"<Label123 width="100px" behaviour="fixed"/>"
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)