using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""[^""]+""|'[^']+')|(?<G><\s?(\w+).*\/>)";
string input = @" <div>
TESAT ${this.TT1}
${am.map( (item, i) => `<li>${item}</li>${i}`).join('')}
<Label width=""100px"" behaviour=""fixed"" />
< Label123 width=""100px"" behaviour=""fixed"" />
""<Label123 width=""100px"" behaviour=""fixed""/>""
</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}