$re = '/(?:"[^"]+"|\'[^\']+\')|(?<G><\s?(\w+).*\/>)/mi';
$str = ' <div>
TESAT ${this.TT1}
${am.map( (item, i) => `<li>${item}</li>${i}`).join(\'\')}
<Label width="100px" behaviour="fixed" />
< Label123 width="100px" behaviour="fixed" />
"<Label123 width="100px" behaviour="fixed"/>"
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);