#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S*HTTPS*_SERVER\S*)(\s*'https*:\/\/)(\S*)('\);)$"
Local $sString = "define('HTTP_SERVER', 'http://localhost:31270');" & @CRLF & _
"define('HTTPS_SERVER', 'https://localhost:31270');"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")