re = /^(\S*HTTPS*_SERVER\S*)(\s*'https*:\/\/)(\S*)('\);)$/m
str = 'define(\'HTTP_SERVER\', \'http://localhost:31270\');
define(\'HTTPS_SERVER\', \'https://localhost:31270\');'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end