import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S*HTTPS*_SERVER\\S*)(\\s*'https*:\\/\\/)(\\S*)('\\);)$";
final String string = "define('HTTP_SERVER', 'http://localhost:31270');\n"
+ "define('HTTPS_SERVER', 'https://localhost:31270');";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}