$re = '/^(\S*HTTPS*_SERVER\S*)(\s*\'https*:\/\/)(\S*)(\'\);)$/m';
$str = 'define(\'HTTP_SERVER\', \'http://localhost:31270\');
define(\'HTTPS_SERVER\', \'https://localhost:31270\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);