const regex = /^(\S*HTTPS*_SERVER\S*)(\s*'https*:\/\/)(\S*)('\);)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S*HTTPS*_SERVER\\S*)(\\s*\'https*:\\\/\\\/)(\\S*)(\'\\);)$', 'gm')
const str = `define('HTTP_SERVER', 'http://localhost:31270');
define('HTTPS_SERVER', 'https://localhost:31270');`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}