#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)Server item:(.*?)[\r\n]+ *Identity:(.*?)[\r\n]+ *Allow: ?(.*?)[\r\n]+ *Deny: ?(.*?)[\r\n]+ *Allow \(Inherited\): ?(.*?)[\r\n]+ *Deny \(Inherited\): ?(.*?)([\r\n]+=|$)"
Local $sString = "Server item: $/The/Path/Goes/Here" & @CRLF & _
" Identity: Identity Number One (TYPE A)" & @CRLF & _
" Allow: " & @CRLF & _
" Deny:" & @CRLF & _
" Allow (Inherited): Read, Write, Checkin, Label" & @CRLF & _
" Lock, CheckinOther" & @CRLF & _
" Deny (Inherited): item2" & @CRLF & _
"====================================================================" & @CRLF & _
"" & @CRLF & _
"Server item: $/The/Other/Path/Goes/Here" & @CRLF & _
" Identity: Identity Number One (TYPE B)" & @CRLF & _
" Allow: Read, Write, Checkin, Label" & @CRLF & _
" Lock, CheckinOther " & @CRLF & _
" Deny:" & @CRLF & _
" Allow (Inherited): " & @CRLF & _
" Deny (Inherited): item3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")