import re
regex = re.compile(r"Server item:(.*?)[\r\n]+ *Identity:(.*?)[\r\n]+ *Allow: ?(.*?)[\r\n]+ *Deny: ?(.*?)[\r\n]+ *Allow \(Inherited\): ?(.*?)[\r\n]+ *Deny \(Inherited\): ?(.*?)([\r\n]+=|$)", flags=re.DOTALL)
test_str = ("Server item: $/The/Path/Goes/Here\n"
" Identity: Identity Number One (TYPE A)\n"
" Allow: \n"
" Deny:\n"
" Allow (Inherited): Read, Write, Checkin, Label\n"
" Lock, CheckinOther\n"
" Deny (Inherited): item2\n"
"====================================================================\n\n"
"Server item: $/The/Other/Path/Goes/Here\n"
" Identity: Identity Number One (TYPE B)\n"
" Allow: Read, Write, Checkin, Label\n"
" Lock, CheckinOther \n"
" Deny:\n"
" Allow (Inherited): \n"
" Deny (Inherited): item3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")