package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)Server item:(.*?)[\r\n]+ *Identity:(.*?)[\r\n]+ *Allow: ?(.*?)[\r\n]+ *Deny: ?(.*?)[\r\n]+ *Allow \(Inherited\): ?(.*?)[\r\n]+ *Deny \(Inherited\): ?(.*?)([\r\n]+=|$)`)
var str = `Server item: $/The/Path/Goes/Here
Identity: Identity Number One (TYPE A)
Allow:
Deny:
Allow (Inherited): Read, Write, Checkin, Label
Lock, CheckinOther
Deny (Inherited): item2
====================================================================
Server item: $/The/Other/Path/Goes/Here
Identity: Identity Number One (TYPE B)
Allow: Read, Write, Checkin, Label
Lock, CheckinOther
Deny:
Allow (Inherited):
Deny (Inherited): item3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}