using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Server item:(.*?)[\r\n]+ *Identity:(.*?)[\r\n]+ *Allow: ?(.*?)[\r\n]+ *Deny: ?(.*?)[\r\n]+ *Allow \(Inherited\): ?(.*?)[\r\n]+ *Deny \(Inherited\): ?(.*?)([\r\n]+=|$)";
string input = @"Server item: $/The/Path/Goes/Here
Identity: Identity Number One (TYPE A)
Allow:
Deny:
Allow (Inherited): Read, Write, Checkin, Label
Lock, CheckinOther
Deny (Inherited): item2
====================================================================
Server item: $/The/Other/Path/Goes/Here
Identity: Identity Number One (TYPE B)
Allow: Read, Write, Checkin, Label
Lock, CheckinOther
Deny:
Allow (Inherited):
Deny (Inherited): item3";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}