import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Server item:(.*?)[\\r\\n]+ *Identity:(.*?)[\\r\\n]+ *Allow: ?(.*?)[\\r\\n]+ *Deny: ?(.*?)[\\r\\n]+ *Allow \\(Inherited\\): ?(.*?)[\\r\\n]+ *Deny \\(Inherited\\): ?(.*?)([\\r\\n]+=|$)";
final String string = "Server item: $/The/Path/Goes/Here\n"
+ " Identity: Identity Number One (TYPE A)\n"
+ " Allow: \n"
+ " Deny:\n"
+ " Allow (Inherited): Read, Write, Checkin, Label\n"
+ " Lock, CheckinOther\n"
+ " Deny (Inherited): item2\n"
+ "====================================================================\n\n"
+ "Server item: $/The/Other/Path/Goes/Here\n"
+ " Identity: Identity Number One (TYPE B)\n"
+ " Allow: Read, Write, Checkin, Label\n"
+ " Lock, CheckinOther \n"
+ " Deny:\n"
+ " Allow (Inherited): \n"
+ " Deny (Inherited): item3";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}