#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+ +(?<=.{11})"
Local $sString = "Don't want to match below" & @CRLF & _
"1 , 52" & @CRLF & _
"123 ,abc" & @CRLF & _
"1234 abcd" & @CRLF & _
"12345 ,asdht" & @CRLF & _
"123456 ahcb" & @CRLF & _
"" & @CRLF & _
"Don't want to match below" & @CRLF & _
"33406 +%global blind rpttyp ;" & @CRLF & _
"33407 +" & @CRLF & _
"33408 +%let blind=N;" & @CRLF & _
"33409 +%let rpttyp =2;" & @CRLF & _
"33410 +%let var = %sysfunc(cats(blah));" & @CRLF & _
" " & @CRLF & _
"Want to match below" & @CRLF & _
"33413 /*************************************************************************************" & @CRLF & _
"33414 " & @CRLF & _
"33439 17APR2018" & @CRLF & _
"33440 19APR2018" & @CRLF & _
"33441 23APR2018 " & @CRLF & _
"33442 24APR2018" & @CRLF & _
"33443 **************************************************************************************" & @CRLF & _
"33444 Program Notes:" & @CRLF & _
"33445 " & @CRLF & _
"33446 **************************************************************************************/" & @CRLF & _
"33447 options mprint mlogic symbolgen source source2 nobyline;" & @CRLF & _
"33448 " & @CRLF & _
"33449 %let source=%str(myds);" & @CRLF & _
"" & @CRLF & _
"Last goal:" & @CRLF & _
"1 2 4 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")