use strict;
my $str = 'Don\'t want to match below
1 , 52
123 ,abc
1234 abcd
12345 ,asdht
123456 ahcb
Don\'t want to match below
33406 +%global blind rpttyp ;
33407 +
33408 +%let blind=N;
33409 +%let rpttyp =2;
33410 +%let var = %sysfunc(cats(blah));
Want to match below
33413 /*************************************************************************************
33414
33439 17APR2018
33440 19APR2018
33441 23APR2018
33442 24APR2018
33443 **************************************************************************************
33444 Program Notes:
33445
33446 **************************************************************************************/
33447 options mprint mlogic symbolgen source source2 nobyline;
33448
33449 %let source=%str(myds);
Last goal:
1 2 4 ';
my $regex = qr/^\d+ +(?<=.{11})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}