# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+ +(?<=.{11})"
test_str = ("Don't want to match below\n"
"1 , 52\n"
"123 ,abc\n"
"1234 abcd\n"
"12345 ,asdht\n"
"123456 ahcb\n\n"
"Don't want to match below\n"
"33406 +%global blind rpttyp ;\n"
"33407 +\n"
"33408 +%let blind=N;\n"
"33409 +%let rpttyp =2;\n"
"33410 +%let var = %sysfunc(cats(blah));\n"
" \n"
"Want to match below\n"
"33413 /*************************************************************************************\n"
"33414 \n"
"33439 17APR2018\n"
"33440 19APR2018\n"
"33441 23APR2018 \n"
"33442 24APR2018\n"
"33443 **************************************************************************************\n"
"33444 Program Notes:\n"
"33445 \n"
"33446 **************************************************************************************/\n"
"33447 options mprint mlogic symbolgen source source2 nobyline;\n"
"33448 \n"
"33449 %let source=%str(myds);\n\n"
"Last goal:\n"
"1 2 4 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.