import Foundation
let pattern = #"^\d+ +(?<=.{11})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Don't want to match below
1 , 52
123 ,abc
1234 abcd
12345 ,asdht
123456 ahcb
Don't want to match below
33406 +%global blind rpttyp ;
33407 +
33408 +%let blind=N;
33409 +%let rpttyp =2;
33410 +%let var = %sysfunc(cats(blah));
Want to match below
33413 /*************************************************************************************
33414
33439 17APR2018
33440 19APR2018
33441 23APR2018
33442 24APR2018
33443 **************************************************************************************
33444 Program Notes:
33445
33446 **************************************************************************************/
33447 options mprint mlogic symbolgen source source2 nobyline;
33448
33449 %let source=%str(myds);
Last goal:
1 2 4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)