using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+ +(?<=.{11})";
string input = @"Don't want to match below
1 , 52
123 ,abc
1234 abcd
12345 ,asdht
123456 ahcb
Don't want to match below
33406 +%global blind rpttyp ;
33407 +
33408 +%let blind=N;
33409 +%let rpttyp =2;
33410 +%let var = %sysfunc(cats(blah));
Want to match below
33413 /*************************************************************************************
33414
33439 17APR2018
33440 19APR2018
33441 23APR2018
33442 24APR2018
33443 **************************************************************************************
33444 Program Notes:
33445
33446 **************************************************************************************/
33447 options mprint mlogic symbolgen source source2 nobyline;
33448
33449 %let source=%str(myds);
Last goal:
1 2 4 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}