#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^\n,]++)(?=.*,([^\n,@]+$)),(?:(?1)(?:\n|$))?"
Local $sString = "johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com,John Smith" & @CRLF & _
"taylorsmith@gmail.com,Taylor Smith" & @CRLF & _
"jacksmith1@gmail.com,jacksmith@gmail.com,Jack Smith" & @CRLF & _
""
Local $sSubst = "$2,$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)