const regex = /([^\n,]++)(?=.*,([^\n,@]+$)),(?:(?1)(?:\n|$))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\n,]++)(?=.*,([^\\n,@]+$)),(?:(?1)(?:\\n|$))?', 'gm')
const str = `johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com,John Smith
taylorsmith@gmail.com,Taylor Smith
jacksmith1@gmail.com,jacksmith@gmail.com,Jack Smith
`;
const subst = `$2,$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);