re = /([^\n,]++)(?=.*,([^\n,@]+$)),(?:(?1)(?:\n|$))?/m
str = 'johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com,John Smith
taylorsmith@gmail.com,Taylor Smith
jacksmith1@gmail.com,jacksmith@gmail.com,Jack Smith
'
subst = '$2,$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result