using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\n,]++)(?=.*,([^\n,@]+$)),(?:(?1)(?:\n|$))?";
string substitution = @"$2,$1\n";
string input = @"johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com,John Smith
taylorsmith@gmail.com,Taylor Smith
jacksmith1@gmail.com,jacksmith@gmail.com,Jack Smith
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}